Data Entry and Import Errors Resolved

Incident Report for Hargrove Association Insights

Resolved

Data Entry and Import are working as expected.
Posted Feb 02, 2026 - 15:31 CST

Monitoring

iSTAT Import and Data Entry are available again. We will monitor the app throughout the day.
Posted Feb 02, 2026 - 10:12 CST

Identified

The issue has been identified.
Posted Feb 02, 2026 - 10:10 CST

Investigating

iSTAT Data Entry and Import are not accepting 2026 reporting, citing Model Error - Check Model and Model Market Dates. This blocks data entry. We are investigating and will update throughout the day.
Posted Feb 02, 2026 - 09:35 CST
This incident affected: iSTAT (Data Import, Data Entry).